FORO SPAMLOCO


Título de post aparece cortado en Google


Consejos, dudas y todo sobre SEO...
   

Título de post aparece cortado en Google

Notapor Manuel de la Fuente » Jul 2013, 16:24

Tengo este post que como ven se titula [SOLUCIÓN] "No se puede establecer una conexión de datos fiable con el servidor" en Android. Sin embargo, por alguna razón que no alcanzo a comprender, Google lo muestra solo como No se puede establecer una conexión de datos fiable con el servidor.

Imagen

¿Por qué omite el resto del título? He revisado el código sin encontrar nada anormal. Tampoco uso plugins de SEO que pudiesen estar alterando la forma en como los buscadores indexan el sitio. ¿Será por el hecho de que está entre comillas? Y de ser así, ¿por qué omite lo que está fuera de ellas y cómo lo resuelvo?
Avatar de Usuario
Manuel de la Fuente
Nivel 7
 
Mensajes: 551
Registrado: May 2009, 15:33
Ubicación: México
Twitter: @ManuelFte



Re: Título de post aparece cortado en Google

Notapor Alejandro » Jul 2013, 23:44

Creo que es algo que no tiene solución :mrgreen:

Google a veces decide mostrar el título que le parece mejor, aunque en el <title> se tenga otra cosa... si Google lo quiere así será.

Pero en este caso, tal vez el problema son los []... sólo por probar (total, no va a afectar en nada) yo cambiaría los paréntesis rectos por los curvos (SOLUCIÓN) y sacaría las comillas. Luego desde las Herramientas para Webmasters desde Explorar como Google la rastrearía y luego enviaría al índice para que el robot detecte el cambio enseguida.

En teoría... el título se tendría que mostrar bien :mf_bookread:
Avatar de Usuario
Alejandro
Administrador
 
Mensajes: 4100
Registrado: May 2009, 18:28
Ubicación: Uruguay
Twitter: @spamloco

Re: Título de post aparece cortado en Google

Notapor elQuique » Jul 2013, 03:45

Coincido, los chirimbolos raros nunca fueron buenos en los títulos y varios lugares SEOeriles :)
Avatar de Usuario
elQuique
Moderador
 
Mensajes: 2230
Registrado: May 2009, 18:43
Ubicación: Florida, Uruguay
Twitter: @elQuique

Re: Título de post aparece cortado en Google

Notapor Manuel de la Fuente » Jul 2013, 09:54

Dudo que sea eso, tengo otro post también con chirimbolos raros y sale completo:

Imagen

Y ahora que me fijo, tiene hasta comillas también, e incluso paréntesis, y aún así no hay ningún problema. :blink:

Para más extrañeza aún, si checo la URL con la Herramienta de pruebas de datos estructurados, supuestamente debería mostrar el título completo:

Imagen

Mi hipótesis iba a que mi tema o algo en WordPress está haciendo que las comillas se interpreten en el código como

Código: Seleccionar todo
&#8221;


en vez de

Código: Seleccionar todo
&quot;


, pero en vista de que ese otro título está bien, ya no sé qué pensar.

En conclusión, como siempre me ocurre cuando Google tiene algo que ver, yo no entiendo nada. :fever:
Avatar de Usuario
Manuel de la Fuente
Nivel 7
 
Mensajes: 551
Registrado: May 2009, 15:33
Ubicación: México
Twitter: @ManuelFte

Re: Título de post aparece cortado en Google

Notapor Manuel de la Fuente » Jul 2013, 10:02

He revisado también en Bing. Mi gran sorpresa fue comprobar que tiene la URL indexada, lo cual ya por sí solo es increíble. Mi otra sorpresa fue que muestra el título completo, pero en la descripción pone algo que no tengo la menor idea de dónde lo sacó:

Imagen
Avatar de Usuario
Manuel de la Fuente
Nivel 7
 
Mensajes: 551
Registrado: May 2009, 15:33
Ubicación: México
Twitter: @ManuelFte

Re: Título de post aparece cortado en Google

Notapor Alejandro » Jul 2013, 04:56

Parece que ya se ven los efectos del cambio:

Imagen
Avatar de Usuario
Alejandro
Administrador
 
Mensajes: 4100
Registrado: May 2009, 18:28
Ubicación: Uruguay
Twitter: @spamloco

Re: Título de post aparece cortado en Google

Notapor Manuel de la Fuente » Jul 2013, 13:32

Avatar de Usuario
Manuel de la Fuente
Nivel 7
 
Mensajes: 551
Registrado: May 2009, 15:33
Ubicación: México
Twitter: @ManuelFte

Re: Título de post aparece cortado en Google

Notapor elQuique » Jul 2013, 23:22

No imagino que puede tener que ver un pony rosa con una conexión de datos pero bue ...
Avatar de Usuario
elQuique
Moderador
 
Mensajes: 2230
Registrado: May 2009, 18:43
Ubicación: Florida, Uruguay
Twitter: @elQuique