FORO SPAMLOCO


Funcion en excel


HTML, CSS, PHP, JavaScript, Java... tus dudas por aquí...
   

Funcion en excel

Notapor Emiliano Zapata » Abr 2014, 07:16

Buen dia compañeros, solicito su grandioso apoyo para poder realizar una función en Excel de horarios de entrada de trabajo, explico:

estoy manejando en una columna el formato de horario de 24 horas, ejemplo 23:55 .

se manejan 3 turnos, los horarios de entrada son a las 8:00 am , 16:00 pm y 24:00 .

Si por ejemplo alguien tiene registrada su entrada a las 07:45, llego 15 minutos antes, entonces al pegar en una celda quisiera que quedaran así:

celda 1 celda 2
-15 07:45
0 04:00
-5 03:55
10 00:10
20 04:20

Espero haberme explicado bien.

Saludos a todos que se encuentren bien. ;-)
Emiliano Zapata
Nivel 4
 
Mensajes: 125
Registrado: Jul 2009, 14:35



Re: Funcion en excel

Notapor federico » Abr 2014, 18:38

Emiliano Zapata escribió:Buen dia compañeros, solicito su grandioso apoyo para poder realizar una función en Excel de horarios de entrada de trabajo, explico:

estoy manejando en una columna el formato de horario de 24 horas, ejemplo 23:55 .

se manejan 3 turnos, los horarios de entrada son a las 8:00 am , 16:00 pm y 24:00 .


Resolverlo es más difícil de lo que parece porque por ejemplo si alguien marca a las 20:00 cómo hacemos? Consideramos que llegó 4 horas tarde al turno de las 16 o que llegó 4 horas antes al de las 24?

Además como no se pueden restar horas o minutos y que te den números negativos hay que preguntar antes si la hora del turno menos la hora de entrada real es negativa o no.

Acá tienes unas pistas:
http://office.microsoft.com/es-es/excel ... 70468.aspx

"http://office.microsoft.com/es-es/excel-help/calcular-la-diferencia-entre-dos-horas-HP010070468.aspx"

Yo lo resolvería con funciones SI, HORA, MINUTO pero es algo engorroso, si no puedes resolverlo luego lo veo con más tiempo.
federico
Nivel 10
 
Mensajes: 2245
Registrado: Ene 2011, 17:26
Twitter: @

Re: Funcion en excel

Notapor Emiliano Zapata » Abr 2014, 03:22

Gracias por la respuesta Federico, checare el link que me envías, respecto a lo que pueden llegar mas tarde, por ejemplo:

Si un trabajador su horario de entrada es a las 16:00, y se reporta a las 16:50, quedaría en la celda como 50, que serian los minutos que llego tarde, se manejaría mas tardar 59 minutos después de la hora o antes de la hora - 59, para que se maneje solo en minutos ya sea positivos o negativos.

Le seguiré intentando, haber si lo resuelvo.

Gracias por su apoyo.
Emiliano Zapata
Nivel 4
 
Mensajes: 125
Registrado: Jul 2009, 14:35

Re: Funcion en excel

Notapor Emiliano Zapata » Abr 2014, 09:04

Encontré un ejemplo que creo se parece a lo que intento realizar, pero me salía un error, no lo pude hacer funcionar:

Operario Ingreso Salida Hora/estándar Diferencia
Operario A 8:25 16:00 8:00 =SI(C2-B2<D2;"-"&TEXTO(D2-(C2-B2);"hh:mm");C2-B2-D2)
Operario B 8:42 16:00 8:00

Gracias por su apoyo.
Emiliano Zapata
Nivel 4
 
Mensajes: 125
Registrado: Jul 2009, 14:35

Re: Funcion en excel

Notapor federico » Abr 2014, 09:45

Emiliano Zapata escribió:Encontré un ejemplo que creo se parece a lo que intento realizar, pero me salía un error, no lo pude hacer funcionar:

Operario Ingreso Salida Hora/estándar Diferencia
Operario A 8:25 16:00 8:00 =SI(C2-B2<D2;"-"&TEXTO(D2-(C2-B2);"hh:mm");C2-B2-D2)
Operario B 8:42 16:00 8:00

Gracias por su apoyo.


Sube la planilla que estás creando a un servidor y comparte el enlace así la veo.
federico
Nivel 10
 
Mensajes: 2245
Registrado: Ene 2011, 17:26
Twitter: @

Re: Funcion en excel

Notapor Emiliano Zapata » Abr 2014, 22:09

En esta pagina encontre esa informacion, pero no viene en plantilla esta en imagen, no la pude hacer funcionar:

http://blog.video2brain.com/es/truco-ex ... ivas-2.htm

Saludos y gracias.
Emiliano Zapata
Nivel 4
 
Mensajes: 125
Registrado: Jul 2009, 14:35

Re: Funcion en excel

Notapor Emiliano Zapata » Abr 2014, 03:21

Alguien quien pueda ayudarme e ilustrarme?


Saludos.
Emiliano Zapata
Nivel 4
 
Mensajes: 125
Registrado: Jul 2009, 14:35

Re: Funcion en excel

Notapor Emiliano Zapata » Abr 2014, 19:19

Que tal amigos, pues les dejo la solucion,aunque no funciona como yo queria, pero funciona :

Operario Ingreso Hora/estandar Diferencia
Operario A 8:00 8:00 -00:00
Operario B 8:42 8:00 42:00

La formula es la siguiente :

=SI(B2<=C2,"-"&TEXTO(C2-B2,"mm:ss"),""&TEXTO(B2+C2,"mm:ss"))

Saludos.
Emiliano Zapata
Nivel 4
 
Mensajes: 125
Registrado: Jul 2009, 14:35